aboutsummaryrefslogtreecommitdiffhomepage
path: root/shell.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2020-10-13 14:09:43 -0400
committerRalph Amissah <ralph.amissah@gmail.com>2020-10-19 14:43:00 -0400
commit2d9778dc01c8ca6c5a915e1ee638251878990d10 (patch)
tree27a850e0eaf74937f78e7486552510cf954bc620 /shell.nix
parentnixify step (diff)
build nix derivation (using dub2nix helper tool)
- nix-shell - nix-build - dub2nix (dub to nix helper tool) - Lionello Lunesu - MIT License - https://github.com/lionello/dub2nix
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix24
1 files changed, 14 insertions, 10 deletions
diff --git a/shell.nix b/shell.nix
index b226cd3..31cfcfb 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,17 +1,21 @@
{ pkgs ? import <nixpkgs> {
overlays = [
(import ./nixDevEnv/overlays/ldcVersion.nix)
- (import ./nixDevEnv/overlays/dmdVersion.nix)
]; }
}:
- pkgs.mkShell {
- buildInputs = with pkgs; [
- dub
- ninja
- #meson
- dmd
- ldc
- sqlite
- validatePkgConfig
+let
+ dub2nix-src = fetchTarball {
+ url = "https://github.com/lionello/dub2nix/archive/master.tar.gz";
+ };
+ dub2nix = (import dub2nix-src) { inherit pkgs; };
+in pkgs.mkShell {
+ buildInputs = with pkgs; [
+ nix
+ dub
+ ldc
+ rdmd
+ sqlite
+ dub2nix
+ nix-prefetch-git
];
}