aboutsummaryrefslogtreecommitdiffhomepage
path: root/shell.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2021-01-02 14:06:16 -0500
committerRalph Amissah <ralph.amissah@gmail.com>2021-01-23 17:01:15 -0500
commit4437c10fad8925d6322c83bf1553daa9a36ceb31 (patch)
tree6d5a85e7d5da7d41320a9773bb8830ef4908e3df /shell.nix
parentnix shebangs, consider (diff)
nix, work on build
Diffstat (limited to 'shell.nix')
-rwxr-xr-x[l---------]shell.nix12
1 files changed, 11 insertions, 1 deletions
diff --git a/shell.nix b/shell.nix
index e102643..4edc4bd 120000..100755
--- a/shell.nix
+++ b/shell.nix
@@ -1 +1,11 @@
-nixEnv/shells/shell-ldc-verNix.nix \ No newline at end of file
+#!/usr/bin/env -S nix-shell
+{ pkgs ? import <nixpkgs> {} }:
+pkgs.mkShell {
+ buildInputs = with pkgs; [
+ (import ./nix/shell-packages.nix { inherit pkgs; })
+ ];
+ shellHook = ''
+ nix-build
+ echo "built spine @ ./result/bin/spine"
+ '';
+}