aboutsummaryrefslogtreecommitdiffhomepage
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rwxr-xr-x[l---------]shell.nix12
1 files changed, 11 insertions, 1 deletions
diff --git a/shell.nix b/shell.nix
index e102643..4edc4bd 120000..100755
--- a/shell.nix
+++ b/shell.nix
@@ -1 +1,11 @@
-nixEnv/shells/shell-ldc-verNix.nix \ No newline at end of file
+#!/usr/bin/env -S nix-shell
+{ pkgs ? import <nixpkgs> {} }:
+pkgs.mkShell {
+ buildInputs = with pkgs; [
+ (import ./nix/shell-packages.nix { inherit pkgs; })
+ ];
+ shellHook = ''
+ nix-build
+ echo "built spine @ ./result/bin/spine"
+ '';
+}