aboutsummaryrefslogtreecommitdiffhomepage
path: root/shell.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2023-02-21 16:32:11 -0500
committerRalph Amissah <ralph.amissah@gmail.com>2023-02-28 13:19:16 -0500
commit9598bd7275bec260f8f1131ae196d3a5f1e26617 (patch)
tree84885cbd312f4dfe44a1ca6e8a3c1d6eb48abc22 /shell.nix
parentnix flake & build, devShells etc. (diff)
nix flake & build, temp. remove gdc
Diffstat (limited to 'shell.nix')
-rwxr-xr-xshell.nix84
1 files changed, 26 insertions, 58 deletions
diff --git a/shell.nix b/shell.nix
index c7eb24c..98902e2 100755
--- a/shell.nix
+++ b/shell.nix
@@ -4,34 +4,39 @@
with pkgs;
mkShell {
buildInputs = [
+ # ❯❯❯ nix_related
#nix
direnv
+ #cachix
nixVersions.unstable #nixFlakes
nix-prefetch-git
validatePkgConfig
- nix-tree jq nix-output-monitor
+ nix-output-monitor
+ nix-tree
+ jq
git
gnumake
ps
- ### d_build_related
+ # ❯❯❯ d_build_related
+ # ❯❯ package manager
dub
- ## compiler
+ # ❯❯ compiler
ldc
- rund
- ## linker
+ #rund
+ # ❯❯ linker
#lld
#mold
- ## builder
+ # ❯❯ builder
#ninja
#meson
- ### sqlite search related
+ # ❯❯❯ sqlite search related
sqlite
- ### pdf_latex_related
+ # ❯❯❯ pdf_latex_related
# source-sans-pro
# source-serif-pro
# source-code-pro
# texlive.combined.scheme-full
- ### xml_and_epub_related
+ # ❯❯❯ xml_and_epub_related
# libxml2
# html-tidy
# xmlstarlet
@@ -41,63 +46,26 @@ mkShell {
# sigil
# calibre #(suite includes: ebook-viewer)
# foliate
- ### i18n translation related
+ # ❯❯❯ i18n translation related
# perl534Packages.Po4a
];
shellHook = ''
- #if [[ -f ".envrc" ]]; then
- # source .envrc
- #fi
nix flake update
- echo ""
- echo "nix flake metadata:"
- nix flake metadata
- echo ""
- echo "nix flake check:"
nix flake check
- echo ""
- echo "nix flake show:"
nix flake show
- echo "
- nix flake update
- nix flake metadata
- nix flake check
- nix flake show
+ echo '
+ shell.nix echo ❯❯
- nix build or nix develop? (suggestions):
+ ❯❯ nix flake update && nix flake check --show-trace && nix flake show && nix develop ".#devShell" -c zsh
- - nix build
- nix build .#default --print-build-logs
- nix build --print-build-logs
- nix build .#default --print-build-logs |& nom
+ ❯❯ nix develop
+ ❯❯ nix develop -c zsh
- - nix run
- nix run .#default --print-build-logs
- nix run default.nix --print-build-logs
-
- - nix shell
- nix shell --print-build-logs --command spine -v
-
- - nix develop
- nix develop --build .#default --print-build-logs
- nix develop --build -f derivation.nix -I .envrc --print-build-logs
- nix develop ; eval \$buildPhase
-
- nix-build |& nom
-
- spine -v
-
- nix-instantiate | nix show-derivation | jq
- nix-build . --no-out-link | xargs -o nix-tree
- nix-tree --derivation .#default
-
- nix flake update && nix flake check --show-trace && nix flake show && nix develop .#devShell
- nix build .#default --print-build-logs
-
- - nix build .#spine-dmd --print-build-logs
- - nix build .#spine-ldc --print-build-logs
- - nix build .#spine-gdc --print-build-logs
- "
- #echo "ldc `${pkgs.ldc}/bin/ldc2 -v`"
+ ❯❯ nix build
+ ❯❯ nix build ".#default" --print-build-logs
+ ❯❯ nix build ".#spine-dmd" --print-build-logs |& nom
+ ❯❯ nix build ".#spine-ldc" --print-build-logs |& nom
+ ❯❯ nix build ".#spine-gdc" --print-build-logs |& nom
+ '
'';
}